• 11/06/2015 às 01:07

    Alguns plugins que estou tentando instalar diretamente da Extension Warehouse (Skalp, Buildedge PRO) do SU estão dando o seguinte erro:

    Erro ao carregar o arquivo C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp/Skalp_loader.rb
    Error: The RubyEncoder loader is not installed. Please visit the http://www.rubyencoder.com/loaders/ RubyEncoder site to download the required loader for “mingw” and unpack it into “C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp/rgloader” directory to run this protected script.
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp/rgloader/loader.rb:21:in `
    C:/Program Files/SketchUp/SketchUp 2015/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require”
    C:/Program Files/SketchUp/SketchUp 2015/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require”
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp/Skalp_loader.rb:6:in `

    C:/Program Files/SketchUp/SketchUp 2015/Tools/extensions.rb:197:in `require”
    C:/Program Files/SketchUp/SketchUp 2015/Tools/extensions.rb:197:in `load”
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp.rb:62:in `register_extension”
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp.rb:62:in `load_extension”
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp.rb:48:in `check_IE_version”
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp.rb:88:in `
    C:/Users/Fábio/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Skalp_Skalp.rb:25:in `

    Já procurei nessas pastas e os arquivos estão todos lá, me parece algum erro de leitura. Alguém tem alguma idéia de como solucionar isso?

    Obrigado.

  • 11/06/2015 às 03:30

    FabioShigihara, seja bem vindo ao fórum!

    Vc verificou se esses plugins são compatíveis com a versão do SU que vc está usando?
    Na Extension Warehouse, quando selecionamos um plugin, abre a página com as informações sobre ele e do lado direito aparece uma barra cinza com algumas informações, dentre elas está o “SketchUp Compatibility”.
    Dei uma olhada lá e o Skalp é compatível com o SketchUp 2014 e o 2015.

  • 12/06/2015 às 13:55

    Fabio, outras duas coisas que podem estar acontecendo:

    – alguns plugins as vezes requerem que você instale um outro plugin para que funcione.

    – segunda opção: Caracteres especiais no nome de usuário. Como os plugins em sua maioria são em inglês, o os caracteres “á” de Fábio, “ã” de João não existem, e o plugin não consegue encontrar o caminho correto da pas “C:/users/João …Plugins”

  • 18/06/2015 às 02:58

    A versão do Ruby presente no SketchUp 2015 já é capaz de ler caminhos de pastas com caracteres que não são ASCII. Prova disso é que na mensagem de erro, o usuário está descrito como Fábio. Se fosse isso, apareceria como Fábio ou outra coisa diferente.

    Acho que o Fábio precisa nos dar mais informações, como:

    Seu Windows é XP?

    Foi uma instalação limpa, Ctrl+C – Ctrl+V de outra instalação ou você já tinha instalado e atualizou a versão?

    Qual a versão do seu Skalp?
    O suporte para 64bits foi incluso a partir da versão v1.0.0320

    Todos estes arquivos estão presentes na pasta rgloader?

    Abra o Ruby console no menu Window, digite o seguinte código e aperte enter

    RUBY_PLATFORM.scan(/^([A-Za-z0-9_]+)-([A-Za-z_]+)/)[0]

    Se for x64, deve estar faltando o rgloader20.mingw.x64.so, do contrário falta o rgloader20.mingw.so.

    Se todos os arquivos estão presentes, entre em contato com o desenvolvedor, informando a versão do SO, versão do SU, Internet Explorer e etc.

  • 08/07/2015 às 14:59

    Galera, o erro era o o “á” do meu nome Fábio. Fiz um novo usuário do windows sem caracter especial e funcionou. Muito obrigado pela atenção.

    Abraços!

  • 30/03/2016 às 15:00

    Não estou conseguindo baixar também. No meu caso o Edge Tools. Se procuro pelo Warehouse ele da a seguinte mensagem:
    A página requisitada não pode ser encontrada.
    E baixando o plugin de outras fontes, quando instalo no sketch ele aparece da seguinte forma:
    Capturar

    Agradeço se puderem me ajudar.

  • 30/03/2016 às 20:38

    @aaliniw, o TT_LIB² é tipo uma biblioteca necessária para alguns plugins desenvolvidos pelo thomthom, portanto deve ser instalada, da mesma forma que um plugin, para que o Edge Tools funcione!

    Links para download:

    TT Library v2.10.4

    Edge Tools v2.1.3

    Obs.: Para fazer download no site SketchUcation vc deve se cadastrar.

  • 31/03/2016 às 00:13

    hmmmmmmmm.. Entendi. Muitíssimo obrigada @danielreple 😀