V-Ray

V-ray 3.4 travando no framebuffer

Este tópico contém respostas, possui 16 vozes e foi atualizado pela última vez por  Deoclides Alves 1 semana, 5 dias atrás.

  • Autor
     |  14877 Views Posts
  • #157441

    Bom dia,

    Estou usando o sketchup 2017 com o v-ray 3.4 e os dois programas travam quando clico em render ou show frame buffer, como na imagem a seguir:
    (mesmo com projeto vazio)

    Já atualizei o drive da placa de vídeo e reinstalei o v-ray 3.4 mas continua o problema.

    O estranho é que quando instalei o v-ray na primeira vez, o programa funcionou perfeitamente por vários dias, e do nada começou o problema. O mesmo aconteceu em outro notebook.

    Alguém sabe qual pode ser a solução?

    Setup: i7 4810mq, 8GB ram, gtx 850M, windows 10 home single language.

  • #157470

    Pode ser alguma atualização do windows 10, veja essa postagem do maurocampos:

    https://sketchupbrasil.com/grupos/geral/forum/topic/sketchup-2016win10-muito-lento/#post-156316

  • #157481

    @danielreple Obrigado pela sugestão, mas parece que não é essa a causa do problema. Encontrei um documento da Chaos Group dizendo que esse problema está recorrente e devem fazer alguma atualização para arrumar. O link do documento:
    ftp://204.10.35.16/Vray/VRay_3_for_SketchUp_Frame_Buffer_Freeze.pdf

    A solução deles é:
    ir em C: > Usuário > “nome do usuário” > AppData > Roaming > ChaosGroup > V-Ray 3.4 for SketchUp (talvez a pasta appdata esteja oculta);
    Então move ou deleta o arquivo “FrameBufferState.fbs”;
    Abre o sketchup, clica na opção Show Frame Buffer, afasta a janela que aparece do centro da tela (não sei porque);
    Clica no ícone “H” lá em baixo (Show VFB History Window);
    Na aba ao lado que vai aparecer, clicar no símbolo de ligar, (enable VFB history)
    E o problema pode ser resolvido.

    Contudo, o documento diz que ao apagar o “FrameBufferState.fbs” já resolve o problema. E realmente só isso basta.

    Mas infelizmente toda vez que usa o render, esse arquivo é recriado, e na próxima vez que abre o sketchup e tento usar o render o programa trava novamente.

    Alguém sabe para que serve esse arquivo? E como funciona esse VFB history (pois tem umas opções nele que talvez possa resolver algo)?

  • #157567

    O VFB history serve pra vc salvar o render para que possa abrir novamente posteriormente no Frame Buffre, caso precise refazer parte do render, salvar em outro formato de imagem, pausar o render pra continuar depois (precisa de uma técnica específica), entre outras coisas.

    Não sei qual a função do FrameBufferState.fbs

    Parece que a Chaos está trabalhando pra corrigir este erro q está acontecendo com algumas pessoas, então deve sair na próxima atualização.

    Como continua acontecendo com vc, já tentou fazer esse processo, menos excluir o arquivo, antes de renderizar?

    Valeu por compartilhar a solução temporária do problema!

    • #160128

      Perfeito meu caro, estava com este problema e você me salvou

  • #157896

    @rafael-prates eu estava com o mesmo problema que o seu e seguindo essas dicas que você achou no site da Chaos  Group consegui reverter!

    Tente novamente! 🙂

  • #157960

    Olá, comigo está acontecendo a mesma coisa que com o Rafael-Prates, o Frame Buffer está travado e isso começou quando abri o History.

    Tentei excluir o arquivo FrameBufferState.fbs, mas não estou conseguindo localizá-lo, pois não está na pasta indicada (V-Ray 3.4 for SketchUp). Alguém me ajuda por favor?

    Obrigada

  • #157963

    @aline-karpinski, pode ser que a pasta “AppData” esteja oculta. Com uma janela aberta, pode ser em “Meu computador”, no menu vá em “Exibir” e marque a opção “Itens ocultos”.

  • #157992

    Olá pessoal, tentando contribuir, tive os mesmos problemas que o @rafael-prates. Consegui resolver de vez a questão clicando na propriedade do arquivo “FrameBufferState.fbs”e ocultei ele.

     

  • #158321

    Gentemmmm, o problema acima só funcionava com projetos novos, um projeto antigo, ele travava da mesma maneira. Como resolvi? Fiz os mesmos procedimentos indicados acima, porém quando habilitei o botão ENABLE VFB HISTORY , na telinha em que se abriu, eu indiquei o mesmissimo caminho do arquivo ao qual deletamos. e funcionou direitinho! 😉

     

  • #158514

    Valeu, pessoal! Consegui resolver o problema!!!

    😀

  • #158756

    Nossa, @rafael_prates, salvou a minha vida! Muito obrigada pela dica! (:

  • #159523

    Fala pessoal,

    Primeiramente, não sou da área e nem entendo da ferramenta, mas ajudei um amigo hoje a resolver o problema no Sketchup 2017 com o V-ray 3.4

    A tela ficava igual a imagem que o amigo postou, mas diferente dele não foi a questão da placa de vídeo.

    A solução do problema foi remover um arquivo que fica na pasta abaixo:

    C:\Users\SEU_USUARIO\AppData\Roaming\Chaos Group\V-Ray 3.4 for SketchUp

    Observação: troque no caminho acima o “SEU_USUARIO” pelo usuário utilizado em seu computador

    O nome do arquivo é: FrameBufferState.fbs

    Para solucionar o problema, fiz para ele um arquivo “batch” que remove automaticamente o arquivo sempre que isso ocorrer.

    Veja abaixo o conteúdo do arquivo:

    Salve o arquivo no local desejado com o nome desejado porém a extensão deve ser .bat, por exemplo: RemoverFrameBuffer.bat

    Sempre que o problema ocorrer, executando o .bat acima deve resolver o problema.

    Bom espero não ter quebrado nenhuma regra do grupo e ter ajudado algumas pessoas.

    Abs !

    **Notei que um amigo acima já havia dado a dica, vou manter pois acredito que o batch pode auxiliar nisso tudo 🙂 **

    • Esta resposta foi modificada 9 meses, 1 semana atrás por  Romulo Santos.
  • #159649

    Não resolveu o problema do travamento apagando o framebuffer =( . Tem hora que fala que está sem espaço na pasta temp! O que será? O Mesmo erro acontece em todos os meus computadores.

  • #159952

    Fiz o que o @rafael-prates sugeriu, e piorou a situação. Agora o Vray (3.4) trava completamente na hora do render. Depois que fiz o procedimento de Enable VFB History, abre o Render History Settings, e a partir disso ele travou e não fecha mais! Também tentei desabilitar o drive da placa de vídeo, mas nada mudou. Também apaguei o FrameBufferState.fbs e nada!

    Agora sempre que tento renderizar, essa janela (Render History Settings) abre e não fecha de jeito nenhum. Trava tudo e não renderiza! Meu windows é o 7 Ultimate.

     

  • #160813

    @romulo-santos  Cara muito obrigado! e as pessoas deste post. Fiz o arquivo bat e não funcionou. Ae eu criei um atalho da pasta na área de trabalho. Obrigado por compartilhar. Essa combinação Sketchup 2017 + vray 3.4 + win 10 é venenosa. Todo dia um leg diferente. No meu caso aqui funcionou blz apagando o arquivo “FrameBufferState.fbs” Salvou o dia! Muito Obrigado!

  • #160926

    para mim não aparece o arquivo “FrameBufferState.fbs” mesmo colocando para ver arquivos ocultos, o que eu faço?

    • Esta resposta foi modificada 4 meses atrás por  lizandra.
  • #161355

    Olá pessoal;

    Eu tive o mesmo problema com o framebuffer e tentei localizar a pasta chaosgroup em roaming e ela estava oculta( mas não sabia ), então achei este site e gostaria de compartilhar com vocês, se me ajudou … também ajudaria vocês meus caros;

    https://qualificad.com.br/vray-travado-no-sketchup/

    Abraço!

  • #160012

    Olá, nunca tinha utilizado o V-ray e resolvi instalar no meu notebook a versão 3.4 para aprender, porém toda vez que tento renderizar a página do Frame buffer trava e logo em seguida trava o Sketchup. Pensei no inicio que poderia ser o arquivo muito pesado, porem mesmo quando coloco apenas 1 ou 2 objetos e tento renderizar o mesmo ocorre.

    Já desinstalei umas 2 vezes e não mudava, então procurei na internet para ver se mais pessoas tinham  o mesmo problema, e encontrei pessoas sugerindo que deletasse o arquivo  “FrameBufferState.fbs”, seguindo todos os passos não localizei o arquivo, mesmo colocando a opção de exibir arquivos ocultos.

    Alguém tem alguma outra solução, por favor??

    Segue as configurações do meu notebook:

    Inspiron 5558

    Processador: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.40GHz

    RAM 8,00G

    64-bit

    Windows 10

  • #160026

    @andressa-fortuna, Ultimamente só vejo o pessoal com win 10 tendo muitos problemas com o skt…

    Vamos ver se pelo menos melhora a situação aí pra vc!

    • Abra o “V-Ray Asset Editor”
    • Vá em Settings
    • Clique na setinha da direita, para expandir a janela
    • Agora em “Global Illumination”, em “Primary Rays” mude de “Brute force” para “Irradiance map”.

Você deve fazer login para responder a este tópico.